Ο μετεωρολογικός μας σταθμός

Weather Underground PWS IDRAMA3

Μ.Κ.Δ. Λύση

Share

Η παρακάτω λύση δόθηκε από τον μαθητή της Γ τάξης,  Τάσο Γρηγοριάδη:

 

ΠΡΟΓΡΑΜΜΑ Μ_Κ_Δ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: μ, ν, ΜΙΝ, τ, ΔΙ, Δ2

ΛΟΓΙΚΕΣ: flag

ΑΡΧΗ

ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ " Δώσε 2 ακαίρεους θετικούς"

ΔΙΑΒΑΣΕ μ, ν

ΜΕΧΡΙΣ_ΟΤΟΥ μ > 0 ΚΑΙ ν > 0

ΑΝ μ < ν ΤΟΤΕ

ΜΙΝ <- μ

ΑΛΛΙΩΣ

ΜΙΝ <- ν ΤΕΛΟΣ_ΑΝ

τ <- ΜΙΝ

flag <- ΨΕΥΔΗΣ

ΟΣΟ flag = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ

ΔΙ <- μ MOD τ

ΑΝ ΔΙ = 0 ΤΟΤΕ

Δ2 <- ν MOD τ

ΑΝ Δ2 = 0 ΤΟΤΕ

flag <- ΑΛΗΘΗΣ

ΑΛΛΙΩΣ

τ <- τ - 1

ΤΕΛΟΣ_ΑΝ

ΑΛΛΙΩΣ

τ <- τ - 1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ " Μέγιστος Κοινός Διαιρέτης", τ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

4ο ΓΕΛ Δράμας

Αθηνάς 30, 66100 Δράμα
Τηλ. 2521048636
Fax. 2521048689
email: 4lykdram (παπάκι) sch (τελεία) gr

Ομάδα Ρομποτικής

Ομάδα Ρομποτικής
Project Hydrobot

Ομάδα Φυσικής

Ομάδα Φυσικής
Παρά 4ο
100 χρόνια μετά
Ασφαλές Διαδίκτυο
Το blog του 4ου
Τελευταία ενημέρωση:
Δευτέρα 28/09/2020 08:51
ΔΙΔΕ Δράμας
www.kioulanis.gr
Πλατάκης Φίλιππος
Παναγιώτης Παζούλης
ΣΕΠΛΗΔ
100 Χρόνια Ελεύθερη Δράμα
Παρανέστι VFT

Χιονοδρομικό Φαλακρού

Χιονοδρομικό Φαλακρού

Σπήλαιο Αγγίτη

Σπήλαιο Αγγίτη
Δόξα Δράμας

Ονειρούπολη

Ονειρούπολη Δράμας
<<  Σεπτέμβριος 2020  >>
 Δε  Τρ  Τε  Πε  Πα  Σα  Κυ 
   1  2  3  4  5  6
  7  8  910111213
14151617181920
21222324252627
282930    
-->